Instructions for creating bar coded cover sheets

The Office of the State Controller has designed a process that allows agencies to create their own document cover sheets. These cover sheets include a bar code of the Document Identification Number (Doc ID #), which lets Office of the State Controller make the record available on a web-based document management system.

The process uses Microsoft Word and Microsoft Excel, and incorporates the macro and mail merge functions of these programs. These instructions explain how to use the tools, yet assume that users are familiar with Microsoft Word and Microsoft Excel.

Installation Instructions
Three files are necessary for installation:

· A Free 3 of 9 Extended font – Fre3of9x.ttf

· A Microsoft Excel spreadsheet

· A Microsoft Word mail merge document which is linked to the Excel spreadsheet. The Word document may be customized for your agency.

The files should accompany these instructions, most likely being delivered on a floppy disk or by e-mail.

Saving the Free 3 of 9 Extended font into your fonts folder on your computer’s hard drive

These steps will save the Free 3 of 9 Extended font into the “Fonts” folder in your Windows system folder and will work on most systems. If you encounter problems accessing the Windows folder on your computer, check with your system administrator. 

Font-1)  Go to your computer’s desktop screen.

Font-2)  Find the Free 3 of 9 Extended file from the disk/e-mail that you received -  Fre3of9x.ttf

Font-3)  Click on the file once.

Font-4)  Go to the “Edit” menu. Choose “Copy.”

Font-5)  Open “My Computer” by double clicking on the icon.

Font-6)  Double click on the “C:” drive, or the name of your hard drive.

Font-7)  Double click on the “Windows” folder, (or on “WinNT” if you are using Windows 2000.)

Font-8)  Double click on the “Fonts” folder. (If you don’t see the Fonts folder, you’ll need to click on “Show Files” in the text on the left pane of the window. If that doesn’t work, you may need to ask your system administrator or technical support for assistance.)

Font-9)  Go to the “Edit” menu. Choose “Paste.” This should place the “Fre3of9x.ttf” font file into your fonts folder.

Font-10)  You will need to close Microsoft Word and Microsoft Excel before you can create new cover sheets.

· Every computer used to print cover sheets will need to have the “Free 3 of 9 Extended” bar code font installed. Users can access the Word and Excel files without the font, but the cover sheets will not work on the scanning system unless the bar code is created with this font.
Copy the Word and Excel files to a local disk drive

Copy-1) On your hard drive or a local network drive, identify an appropriate place where you will want to save the Word and Excel files. Consider who else may be creating cover sheets, and whether or not they will need to access the files. Choose a location accordingly.

Copy-2) Go to your computer’s desktop screen.

Copy-3) Find the Word and Excel files from the disk or e-mail that you received. You can open the folder or use Windows Explorer.

Copy-4) Open the folder in which you would like to store these files.

Copy-5) Copy the Word and Excel files to the new location. (You can probably select and drag them to the new location to accomplish this. Or you can use the Copy and Paste commands.)

Copy-6) Close any windows you do not need.

Creating Cover Sheets Instructions
The first task in creating cover sheets is to input the Document Identification Numbers for which you would like the cover sheets. This work is performed using Microsoft Excel.

1) Open the Microsoft Excel spreadsheet 

If the screen below appears (Figure 1.1), click on “Enable Macros.” The Excel spreadsheet uses a macro to create the list of numbers. If you disable the macro, it will not work correctly.
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Figure 1.1

2) Once open, the spreadsheet will look similar to Figure 1.2.
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Figure 1.2

3) To enter a new series of Doc ID #s, you will need to run the macro. First, make sure CAPS LOCK on your keyboard is off. To run the macro, press Ctrl+Shift+R. (While holding down the “Ctrl” and “Shift” keys on the keyboard at the same time, press the “R” key.) If the key command does not work, see Troubleshooting Problem #3.

Note: Running the macro will delete all the Doc ID #s that are on the worksheet. Therefore, make sure you have printed the cover sheets for all Doc ID #s listed, and that the print job worked correctly, before running the macro.

4) The box show in Figure 1.3 will appear.
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Figure 1.3

5) In the box under “Please confirm starting string,” type the first Doc ID #.

6) In the box next to “# of sheets to Generate,” type the number of cover sheets you would like to create.

For example, if you would like to create cover sheets for documents PV99Z0001 through PV99Z0010 you would enter the starting number PV99Z0001, and 10 as the number to generate.

Please note the Doc ID # on the cover sheets must be the same as the number entered into the MFASIS Accounting system, with one exception: cover sheets for P9 documents must begin with PV, and not P9. The Doc ID #s cannot contain any asterisk (*) characters or spaces.

Hints: For the list of sequential numbers to be created, the Doc ID # needs to end with a number, not a letter. If your Doc ID # ends with a letter, the macro will create the same Doc ID # multiple times. To create document ID numbers that end in letters, see Troubleshooting Problem #4.

7) Once you have input numbers into the “Please confirm starting string” and the “# of sheets to Generate” fields, click on “Process.” This step will clear out the contents of the existing worksheet, and create a new worksheet with the new numbers. The box will go away, and a new sheet will look something like Figure 1.5.

If you see Figure 1.4, then you probably entered 1 in the “# of sheets to Generate” box. Click “End.”
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Figure 1.4
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Figure 1.5

8) If the numbers are correct, go to step 9. If the numbers are not correct, return to step 3 and reenter the information.

You can add additional numbers to the list you just created by entering the Doc ID #s at the bottom of the list you just created.

9) Save the Excel file as is (there is no need to change the name). Click on the “File” menu, then on “Save.” Or press CTRL+S.

10) Minimize Excel. (Shrink or hide the Excel window on your screen.)

You have completed work with Excel. The next step is to run a mail merge program in Microsoft Word which will create cover sheets containing the numbers in the list and a bar code.

11)  Open the Microsoft Word mail merge document from your desktop, or from Microsoft Word. (Do not open it from Excel.).  If you are sending the documents to Maine Revenue Services for scanning, open MRS Cover Sheet Mail Merge.doc.  If you are sending the documents to Accounts and Control please open Cover Sheet Mail Merge.doc.
If you are using the Word program for the first time, or if you have moved the Excel file to another folder, you will see a box saying that Word cannot find its data source (Figure 1.6). For instructions on how to handle this, see Problem #1 in the Troubleshooting section at the end of these instructions.
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Figure 1.6

12) If Figure 1.7 appears, click on “Enable Macros.”
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Figure 1.7

The document should open, and look similar to Figure 1.8, with possible modifications for your agency.
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Figure 1.8

13) In the document, you will see «DOCUMENT_ID» in a few places. This indicates a mail merge field in the document
. When the mail merge is run, Microsoft Word will replace the «DOCUMENT_ID» words with the numbers that were created in Excel.

14) Running the mail merge in Word will pull the numbers from Excel and create cover sheets in a new document. You can do this two ways:

· Press Alt+Shift+N. (Hold down the “Alt” and “Shift” keys, and while holding them down press the “N” key.)

· The Mail Merge toolbar often appears when viewing documents setup for mail merge. One of the buttons allows you to “Merge to New Document.” The button is often the 5th from the right side of the Mail Merge toolbar.

This step will create a new document, as shown in Figure 1.9. You can print, edit, and save the new document as a normal Word document. Please do not alter any of the lines in or near the bar code at the bottom of each cover sheet page.
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Figure 1.9

15) To print out cover sheets, go to the “File” menu and select “Print.” Please print the cover sheets on blank white paper using a laser printer. Printing on other types of printers, printing on colored paper, or printing in a low-quality mode may prevent the scanning system from reading the bar code correctly.

16) When you are done working with the new file containing all of the bar coded cover sheets and you have printed the cover sheets, you do not need to save it. Please check to make sure all of the cover sheets printed out property before closing the file.

In order to avoid printing out duplicate sets of cover sheets with the same numbers, agencies may wish to keep a log sheet or similar reminder to track the number of the last cover sheet produced.

17) Close the Microsoft Word and Excel documents and/or exit the programs.

Troubleshooting Instructions

Problem #1 – I cannot find data source when I open the Word file

If you see the message box shown in Figure T1.1 when you open the Microsoft Word document, then Word has “misplaced” the Microsoft Excel spreadsheet where you enter the Doc ID #s. This can happen if you are using the Word program for the first time, or if you have recently moved the Excel spreadsheet file to another folder.
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Figure T1.1

T1-1) Click on “Find Data Source…”

T1-2) In the Open Data Source window that appears (see Figure T1.2), choose “All Files” from the drop-down menu next to “Files of type.” This will show all types of files in the window, instead of just Word documents. Since the spreadsheet is an Excel file, you will need to do this in order to find it on the list.
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Figure T1.2

T1-3) Locate the Excel spreadsheet where you enter the Doc ID #s.

T1-4) Click on Open. Word will open the Excel document.

T1-5) If the window below appears, select “Entire Spreadsheet” and click “OK.”
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Figure T1.3

T1-6) When the document opens, go to the File menu and choose “Save” (not “Save As”). This will save the new settings, you do not need to change the file name.

T1-7) Return to step 13 of “Creating cover sheets.”

Problem #2 – The Word document does not have a bar code on it

If you find that the Word document does not have bar codes at the bottom of the pages, then the computer you are using most likely does not have the bar code font installed. Try to install the font by following the steps for “Saving the Free 3 of 9 Extended font into your fonts folder on your computer’s hard drive” listed in the Installation section of these instructions. The font must be installed on every computer you use to create and print bar coded cover sheets.

Problem #3 – The macro in Excel doesn’t work. (Nothing happens when I press CTRL+Shift+R in the Excel spreadsheet) 

First – check to see if the CAPS LOCK is on. The CAPS LOCK needs to be off for the macro to run properly.

A)

When you opened the Excel spreadsheet, Excel may have disabled the macros in the worksheet. The best bet would be to close the Excel document and open it again. When you open it, be sure you select “Enable Macros.”

In some cases, your version of Excel may be pre-programmed to automatically disable macros, without asking you about it first. The Excel 2000 has a setting which can disable all macros from running. If you press CTRL+Shift+R and the macro does not start, and if you are using Microsoft Excel 2000, then this setting may be the problem. You will need to enable macros. You can do this by going to the Tools menu, then to Macros, then Security. Click on the Security Level tab, and make sure that the Medium button is checked. Close Excel and start again. You may want to check with your system administrator for more information about macros and macro viruses.

B)

Another possible cause would be that the keyboard shortcut (CRTL+Shift+R) no longer works. You can begin the macro manually by following the steps below.

T3.B-1) Click on the Tools menu

T3.B-2) Choose Macro ( Macros… The window below should appear.
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Figure T3-B.1

T3.B-3) If no macros are listed in the box, then the macros did not load when the spreadsheet was opened. Click “Cancel.” Exit Excel. Return to step 1 of the Creating Cover Sheets Instructions.

If macros did appear in the box, then the keyboard shortcut is not working. Go to the next step.

T3.B-4) Click once on “Do Load Form.”

T3.B-5) Click on “Run”

T3.B-6) Return to step 4 of the Creating Cover Sheets Instructions.

Problem #4 – I need to create cover sheets for Document Identification Numbers that end in a letter or non-sequential numbers

If at all possible, please try to construct your Document Identification Numbering system in such a way that the numbers do not end in letters, and that the numbers are sequential. This will save you a lot of time and hassle by not having to perform the steps below. If, however, you do need to have the Doc ID #s end in a letter or be non-sequential, the steps below will let you do so.

T4-1) Run the Excel macro. See steps 1-3 of the Creating Cover Sheets Instructions to get to this point.

T4-2) Enter the first Doc ID # you would like in the “Please confirm starting string” field.

T4-3) Under the “# of sheets to generate” field, enter 2 (or more). Click Process.

If you choose 1, you will get the error message shown in Figure T4.1. If you do see the message, click “End.”
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Figure T4.1

T4-4) A new list of Doc ID #s will appear. You will now need to enter the additional Doc ID #s manually.

T4-5) At the bottom of the list, type in the next Doc ID # for which you would like a cover sheet. Please begin the number with the doc type (PV, JV, etc.) and then your agency number. Use the down arrow to move to the next field. Repeat this step until you have entered all of the desired Doc ID #s.

T4-6) When you have finished entering the numbers, go to step 9 of creating cover sheets.

MAILING INSTRUCTIONS


All documents must be sent via interoffice mail to:
Office of the State Controller

14 SHS

Augusta ME 04333

� If you choose a hard drive, the person using that computer will be able to access the file. If you choose a network drive, several people can access the file, but note that only one person should use it at a time, to avoid accidentally deleting someone else’s work while it is in process.


� Some users of Microsoft Excel 2000 may find the macro does not run properly. The 2000 version of Excel has a setting which can disable all macros from running. If the macro does not start, and you are using Microsoft Excel 2000, then this setting may be the problem. You will need to enable macros. You can do this by going to the Tools menu, then to Macros, then Security. Click on the   Security Level tab, and make sure the Medium button is checked. Close Excel and start again. You may want to check with your system administrator for more information.


� Mail Merge is a built-in function of Microsoft Word. In the mail merge process, the Word document will look at the Excel file for the document ID number. The bar code that you see in the Word document is a mail merge field consisting of the Document ID number, but instead of printing it in a normal font, it appears in the Free 3 of 9 Extended bar code font. PLEASE do not alter any of the text below the horizontal line near the bottom of the page. Doing so may prevent the scanning system from reading the bar code.
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