
Creating a fillable and accessible forms in 
MS Word 2003
Intro:

Fillable forms make things easier for all of your users to navigate and complete forms without having to spend time to clean it up because their typing pushed text and lines around the page.  Fillable forms can also be more accessible.  They “can” be because unless you take the time to make it accessible, it will actually be less accessible than a form without fillable fields.  

Note:  These instructions are based on Microsoft Word 2003, some commands may differ for earlier or subsequent versions.  For those viewing this on a computer, throughout this document, I used actual fillable fields and tables so you may want to lock and unlock the document so that you can test the fillable fields.  Below is a sample image of a table with form fields shaded so that you know what it would look like.  When form is printed the fillable fields don’t show up.  The image also shows the table outline, which also doesn’t show up when printed with the exception of the areas that are darker, such as above the word “First”
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To turn on shading make sure your forms tool bar is displayed by going to View > Tool Bars > Forms.  The forms tool bar looks like this: [image: image2.jpg]o P M|



 Shading is the [image: image3.jpg]


 button (the ‘a’ with the hash marks around it) and the lock on the far right locks and unlocks the document during the testing phase, though this method of protecting the document is not recommended when distributing the document, but that’s covered later in this document. 

You will also want to turn on gridlines to see the outline of your tables, by going to Table > Show Gridlines

Formatting table cells:

In the past, forms have frequently been created by typing what is desired on the line, then creating an underline manually or tabbing over then entering the second field (if having two on one line.)  This worked well for printed forms, but when the form is used electronically, when the user put their cursor on the underlined area and start typing it pushes the line and adjacent text aside.  To prevent this, there are two ways to create fillable forms; individual lines for each item (without an underline for handwriting on), such as :

Name:      
Date of Birth:      
Or use tables to space things out and lock their position on the page, and create underlined areas where a user could handwrite on the printed form.   Such as: 

	Name:
	     
	Date of Birth:
	     


In this example, you can type in the “Name field” without pushing the rest of the text to the right until you reach the end of the cell, then it will start enlarging the cell downwards (when locked).  You can hide some of the lines around the cell leaving only a line where the text form field is or where people should hand write.  This is covered in detail later in this document.  

In the Date of Birth field, you’ll notice that you can enter only enough characters to enter 12/12/2012 not December 12, 2012.  This is done by setting the text field properties, which is covered in detail later, but for now, know that you can limit the number of characters an individual can enter.
Fillable fields:

A fillable field is where a user can type when the form is locked and filling of forms is enabled.  A screen reader is a piece of assistive technology that allows users with visual impairments, print disabilities or other impairment to have text read to them.  A screen reader will read only what is in the text help fields, not the information before or after it.  If this form were locked, so far, the only thing that would be read is the example text fields above.  

To Start:

Start with blank document.

You need to make sure your forms toolbar is turned on by going to View > Toolbars and choose “Forms” which will give you:  
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The buttons explained:
· Text field, allows user to enter text to this area

· Check box, creates check box whose default can be checked or un-checked

· Drop down list, will show drop down list when clicked, and must be custom populated

· Draw Table Allows you to do just that, draw a table, outline first then manually create rows and columns
· Insert Table allows you to quickly create a table (maximum 4x5, larger than this go to Table > Insert > Table

· Form Field Options: Available only when form field is selected. Allows you to add help text

· Create Table; menu that allows you to set rows and columns and creates at once.
· Shade:  Will shade the form fields (useful when working on the form). Can be turned on an off during the work.  
· Erase: Resets form fields
· Lock: Locks the page, causing your cursor to move only between form fields.  Useful during creation and testing, but does not allow you to password protect or set other options in protecting the document.  For this, go to Tools > Protect Document. 
Putting it together:
Okay rather than explaining how to use the buttons and then showing them in action, this is going to be done simultaneously.  For this example the individual will need to enter their name, choose which sex they are, their age, and identify their living situation.  
Create your table:
There are two ways to create a table. First is the insert table button [image: image5.jpg]


 on the forms toolbar which can give you a maximum of 4x5 table.  The other alternative is to go to Table > Insert > Table.  We’re going to start with 3 rows and 5 columns.  I’ve created the table and entered the fields we want below.
	Name
	
	
	
	

	
	First
	Last
	Sex
	Age

	Living situation
	
	
	
	


Before entering the fillable fields, be sure that shading is on.   When its on, the [image: image6.jpg]


  on the forms toolbar is orange [image: image7.jpg]


.  For the first and last name, use Text boxes as we want the person to type their information in.  Place the cursor where you want the text form field and hit the text form field button [image: image8.jpg]


.  
Text Form field

Making text form fields accessible.  Double click the shaded text form field and you will have a dialogue box appear.  
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Click Add Help Text in the bottom left hand corner and you’ll get the right hand dialogue box.  Click in the open area and the radio button will change to “Type your own:” Enter what you want someone to type in this area, you are limited to 118 characters including spaces.  This should mirror what sighted users are seeing.  If it’s the first cell of the document, you may also want to enter the agency and form name and revision date.  So for this first cell, I might put something like “Maine Department of Labor, fillable forms sample revised 7/09.  Please enter first name” Click okay.  Repeat process for for the last name while leaving out the Department, form and revision date.  
Maximum Length

For the name fields, you will likely want to leave the maximum length at unlimited.  However for the age field, you don’t need an unlimited text field.  2 or 3 characters will be the maximum age someone will be, so create a text form field for age, set maximum length to 2 or 3 and enter the alternative text.  
Drop Down menus [image: image11.jpg]



For the sex field, we are going to use a drop down menu.  A text field or check box could be used as it’s a pretty simple field, but for example purposes we’ll use the drop down.  

Place your cursor in the cell above “sex” and click the “Drop Down Menu form field” On the screen it looks just like a text form field initially.  Double click it and you’ll get a menu.[image: image1.jpg]Name
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 This is where you’ll enter the different choices for someone to choose from.  So, in the Drop-Down item field on the left of the menu, enter Male, then hit the add button below it and it’ll be added to the menu to the right.  Do the same for Female.  The Move buttons to the right of the “Items in drop-down list:” allow you to order the items as you want them to appear on your form.  
A word of warning though, which ever item you have at the top will appear as the default text for that field.  So when the person is using the form, it looks like it’s already filled in.  
If male is at the top of the list, it’ll look like this: Male.  The way around this is to put a blank space at the top of the list.  Do this by going to the drop down menu item, and putting in 6-8 spaces then hit the add button.  You won’t see them on the list because they’re spaces, but hit the up button, and you’ll see it put a space between the two other items. Move that space to the top of the list and you’ll get a blank field on your form.  Note: the reason I used 6-8 spaces, is because the field will show as many characters as the option on the list.  When the fillable fields are shaded, one space will appear as a sliver, and 6-8 appear longer  This makes it more obvious, and doesn’t affect the function. 
Last note on drop downs, they are discouraged in web design and form design because they can be difficult to use (for both sighted and visually impaired users).  If you have an alternative, use it, even if it means using a bit more space to put in check boxes or text form field.  

Table structure:

Before we move onto living situation, it’s a good time to talk about manipulating table structure.  Tables in word function similarly to those in Excel in that you can merge and split cells and manipulate their size.  The beauty of word tables is that you can adjust the size of one cell on one line without affecting those below it (if you want). 

Merging cells.  

Cells to be merged must be in a row or column; you cannot make L shaped merges.  Highlight the cells you want to merge, and right click on your mouse or go to “Table” on and choose Merge Cells.  Do this for the entire row next to “Living situation”

It’ll give you one long cell.  

Splitting Cells:
In our example, we have a line for first name and last name, sex and age.  Were we to leave the lines for each of these there’d be no breaks in the line, (which is fine if that’s what you want).  To do this we’ll put a cell between the lines we’re going to leave.  Because we didn’t plan for this from the beginning, we’ll have to split a number of cells,.  You can split only one cell at a time, so choose the cell above the first name and right click. Do the same for Last, and Sex (both the ones with the text and above them).  We didn’t put a space between name and first because “Name” won’t be underlined.  Time to rearrange some things. 
	Name
	
	
	
	
	
	
	

	
	First
	
	Last
	
	Sex
	
	Age

	Living situation


Changing cell shape:

You can change cell shape individually or in blocks by selecting those to be changed.  If no cell(s) are selected, moving the cell line may impact other tables in your document.  To prevent changing the shape of other cells, it’s best to highlight those that you want to change.  

First, resizing cells individually.  You want the name line to start as close to the word “Name” as possible, so you need to move the cell side closer.  To do this, choose either the “Name” cell or the one to the right of it by clicking on the left hand side edge which should make the cell shaded.   Move your mouse to the right until your cursor changes to [image: image12.jpg]o>



, press and hold your left mouse button and slide the cell wall to the left.  This will change just that cell without impacting the others around it.  Do the same for the one below it with “First” in it so that they match.  

These could have been done together, which you’ll do now.  So highlight the two vertical blank cells between first and last.  Push the left or right hand wall towards the other until it won’t go any further. This will form the space between the lines.  Do the same for the blank cells between Last and Sex and again between Sex and Age.
	Name
	
	
	
	
	
	
	

	
	First
	
	Last
	
	Sex
	
	Age

	Living situation


Borders tool
Resizing cells makes it appear more structured.  Next task is to eliminate the unnecessary lines, so we can see how this form will look.  However, you’re still going to want to know where the cell walls are, so go to Table > and at the bottom look for “Hide Gridlines” or “Show Gridlines”. If the first one is on, leave it, because they’re already there, otherwise, hit Show Gridlines. 

To get rid of the borders, first highlight the entire table by hovering your mouse over it until you see [image: image13.jpg]


, click on this and it’ll highlight the entire table.  Go to the tool bar and choose the borders menu [image: image14.jpg]


 and click the one that is all dotted lines (bottom row, second one in from left).  This will clear all borders in the table.  Put your cursor in the cell above “First”, and choose the underline from the same menu.  Do the same for the cells above “Last”, “Sex” and “Age”.   Visually, when the form is viewed on a computer or printed will show people where they should enter information.  

Next we’re going to clean up the middle row, with the “First” “Last” etc on it.  We want to shrink them a bit and center them to the lines so people know that’s where the information goes.  Click on the left hand edge of the middle row. Single click will choose just that first cell, double click will choose the entire row.  Double click to choose the entire row.  Then center and change the font size to suit your desire.  In this case we used 9 pt.  When you changed the font size to 9 pts the cell shrunk with it.  Below is what you should see. 
	Name
	
	
	
	
	
	
	

	
	First
	
	Last
	
	Sex
	
	Age

	Living situation


Check boxes [image: image15.jpg]
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We are going to have three categories of living situation; Rent, Own and Other.  Put in your text choices, and put a check box before each of them by clicking the icon on the forms toolbar.  Double click the checkbox and you’ll get a menu (below) that has the help text option like before as well as settings for the size of the check box and whether it’s checked or not checked as the default.  
For the help text here, you’ll need to make sure people are oriented to where they are on the form if they’re using a screen reader.  A common convention is to use a phrase like “Answer equals”.  So for this example the help text would read; “Living situation answer equals rent.”  And “Living Situation answer equals own” and “Living Situation answer equals other”  

Visually, as the check boxes are not going to change shape when checked, we don’t have to worry about them getting moved around when someone answers.  Because of this, we can insert spaces or tabs where we want space between them, and they’ll be unaffected once the form is locked.   My recommendation is to make sure you put equal spaces between the check box and answer and more space between the first answer and the next.  This allows the check box and answer to be appear visually related to each other, and reduces confusion as to which check box goes with which answer.  

	Name
	     
	
	     
	
	 FORMDROPDOWN 

	
	   

	
	First
	
	Last
	
	Sex
	
	Age

	Living situation:    FORMCHECKBOX 
  Rent        FORMCHECKBOX 
 Own        FORMCHECKBOX 
 Other


In looking at the example above, Living situation looks a little cramped up into the line above.  We can resolve this two ways.  One is to insert another line above Living situation to provide a buffer.  We do this by highlighting the Living situation row, and going to Table > Insert > Row Above.  To make that row smaller, put your cursor in it, and choose a smaller font size, and the cell should shrink to match it.  
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The other way we can give Living Situation some more room is making its cell larger.  We do this the same way we moved the side walls of the cell, hover over the bottom line until your cursor changes, click and hold your left mouse button and pull down.  When you do this, your text stays at the top of the cell still, rather than falling to the bottom. Highlight the cell, and right click, choose Cell Alignment (left).  The default is top left, change this to bottom left.  If doing it to a row that contains multiple cells, you may need to do each cell individually.  
	Name
	     
	
	     
	
	 FORMDROPDOWN 

	
	   

	
	First
	
	Last
	
	Sex
	
	Age

	Living situation:    FORMCHECKBOX 
  Rent        FORMCHECKBOX 
Own        FORMCHECKBOX 
Other


Locking your form:
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Locking the form gives the form it’s functioning.  As mentioned, you can use the lock icon on the forms toolbar, but this allows users to unlock and edit the form.  

It’s recommended that you lock the form by going to Tools >  Protect Document.  This will give you a right hand bar to your page (left hand image).  #2 is Editing Restrictions, check the box to “Allow only this type of editing in the document” and choose “Filling in of forms” in the drop down menu .  Hit the button “Yes, Start Enforcing Protection” will bring up a box where you can put in a password or just hit okay.  If you hit Okay, it’ll still be protected, but someone can unlock it and change the form.  Password protection prevents this, but just be sure you don’t lose the password, because there is not a way to unlock the form for editing without it, and you will need to rebuild the form if you lose the password. (I recommend keeping a protected copy in your personal files and distribute locked versions).
Please note that users will not be able to change font size, bold or italic when forms are protected.  Changes in font after the form is complete could impact how the text fits in a cell, so you need to make sure you check your cells after you change the font.  Especially for those that have small, custom cells, such as age, date etc.   

Help Text and Design notes and tricks:

· When entering help/ alternative text, eliminate or limit use of hyphens, parentheses, colons, semi colons, and  quotation marks as they are read by screen readers and frequently do not contribute content.  For example;  “Example;” would be read “Open quotations example semicolon close parentheses” It adds no value to the user to hear the punctuation.  
· If information you need to convey in a fillable field exceeds the number of characters allowed by the help text.  You can break up into multiple text form field boxes.  Create text form field box, set maximum characters to 1.  You must leave fill in enabled for a screen reader to read the box, which is why we set it to 1. In help text, enter beginning of phrase you need your user to hear followed by “Do not enter text here”.  Then put second text box with remainder of help text.  Can do this with more than one text box.  
· Bullets: The trick above also works for bullets.  In the example below, I shaded the text form fields manually so you can see the size and placement of them.  

· I understand that I am responsible for:

· Keeping my room clean. 
· Saving $5 per week for vacation.  
· Doing my chores daily.  
· Doing all of these without being asked  
In this example the help text for the first bullet reads “I understand that I am responsible for keeping my room clean. Do not enter text here.”  The second bullet reads “I understand that I am responsible for saving $5 per week for vacation. Do not enter text here.”  I included the header to the list in each bullet as well as the “Do not enter text here”. 
· This example also provides a good example of how information may be reused in a form.  Rather than creating four blank text fields and editing all of the information for each one, I created one text field, and added help text that contained the information that was common to all four bullets. This being “I understand that I am responsible for” and “Do not enter text here”.  After copying and pasting that at the end of each bullet, I added the information unique to the line into the help text, such as “Keeping my room clean.”  This can be a tremendous time saver, especially when doing ones with counties, yes no questions or just a series of check boxes.  Not having to type “Answer equals yes” repeatedly can be a huge labor saver.
· You can copy and paste the text areas, help text information or the entire table with all of the help text or just the table structure (before you add the text form fields).  An example of this would be creating a form for job history where the same information may be repeated 4 or 5 times.  Create the table, form fields, help text and do your changes to table layout.  Then copy the entire table and paste four more times.  Naming wise you still need to go back to your Help Text and make each one unique.  It can be as simple as in the first field as “Employer 1 Name”  “Employer 2 Name”, just be sure you use the same naming convention for every one.  
· If you are doing a sheet that has areas for people to fill out that are unlined, I would generally expand the cell area down multiple lines as much as I think someone would use and add a little extra (see below).  This would allow the user to type without changing the size of the form as a whole.   You do this by putting your cursor over the bottom line of the cell until it changes to a horizontal line with an arrow pointing up and down and pull the cell larger (this also works to make cells larger and smaller horizontally).  Do not hit “enter” repeatedly to expand a cell, if you do so, when a user goes beyond one line it will push these down and continue to expand the cell rather than filling it. You will then be left with those blank lines after the user has finished the form.
	Please describe your job duties:      


· Special situations: Social Security Numbers, Dates or phone numbers.  These three examples all have mixture of numbers/letter and characters of some sort, whether parentheses ( ) or hyphens- or slashes /.   For all of these, though either is technically okay, it’s recommended making a single text form field that can accommodate all of the characters rather than separate cells for each set of numbers and letters.  For example, rather than three separate text fields separated by hypens for a social security number, do one text form field for all of the characters (11).  Don’t forget the characters in between letters/numbers unless you specify that’s the format you want.  

	Social Security Number:
	   
	-
	  
	-
	   


Versus
	Social Security Number:
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